0
5 Comments

Tried with default theme: Yes

Tried with all other plugins disabled: Yes

Browser version: Firefox 96.0.3 (64-bit) & Microsoft Edge Version 98.0.1108.43 (64-bit)

Shortcode/URL with the issue: https://youtu.be/qJXmdY4lVR0

Page showing the issue: https://eastofeverest.org/defacing-the-truth-destroying-the-conscience/

Debug Info:

ARVE:               9.7.5
ARVE Pro:           5.2.2
ARVE AMP:           NOT INSTALLED
ARVE Sticky Videos: NOT INSTALLED
ARVE Random Video:  NOT INSTALLED
WordPress Version:  5.9
PHP Version:        7.4.27
REST URL:           https://eastofeverest.org/wp-json/nextgenthemes_arve/v1

ACTIVE PLUGINS:
Absolute Reviews: 1.1.0
Advanced Popups: 1.1.3
ARVE Advanced Responsive Video Embedder: 9.7.5
ARVE Pro Addon: 5.2.2
Better Image Credits: 2.0.3
Canvas: 2.3.4
Co-Authors Plus: 3.4.92
Contact Form 7: 5.5.4
EasyIndex: 1.1.1704
footnotes: 2.7.3
Fox Elementor Addons: 1.4.2
Google Analytics for WordPress by MonsterInsights: 8.3.2
MailPoet 3 (New): 3.78.0
MailPoet 3 Premium (New): 3.78.0
Media Library Assistant: 2.98
Popup Maker: 1.16.4
Powerkit: 2.6.6
RefTagger: 2.4.4
Regenerate Thumbnails: 3.1.5
Relevanssi: 4.14.7
Sassy Social Share: 3.3.38
SearchWP Live Ajax Search: 1.6.1
Secondary Title: 2.0.8
Sight – Professional Image Gallery and Portfolio: 1.0.7
UnderConstructionPage PRO: 5.69
WordPress Popular Posts: 5.5.1
WP Last Modified Info: 1.7.7
Yet Another Related Posts Plugin (YARPP): 5.27.8
Yoast SEO: 18.0

NETWORK ACTIVE PLUGINS: 
PDF Embedder Premium: 4.4.3
ARVE Advanced Responsive Video Embedder: 9.7.5
iThemes Security: 8.0.2
GDPR Cookie Consent: 2.0.9
Custom Post Type UI: 1.10.2
Customizer Export/Import: 0.9.2
English WordPress Admin: 1.5.1
Envato Market: 2.0.7
XML Sitemaps: 4.1.1
Health Check & Troubleshooting: 1.4.5
Insert Headers and Footers: 1.6.0
Kirki Customizer Framework: 3.1.9
MultilingualPress: 3.9.1
TaxoPress: 3.4.4
Testimonial Rotator: 3.0.3
UpdraftPlus - Backup/Restore: 2.22.1.25
WP Content Copy Protection & No Right Click (premium): 10.3
WebMan Templates: 2.2.3
WP-Optimize Premium - Clean, Compress, Cache: 3.2.2

ARVE Options:
array(2) {
  ["mode"]=>
  string(8) "lightbox"
  ["hide_title"]=>
  bool(true)
}

Dismissed Notices:
array(1) {
  [0]=>
  array(1) {
    [0]=>
    string(30) "ngt-arve_pro-activation-notice"
  }
}

oembed_dataparse:
Array
(
    [0] => Array
        (
            [id] => wp_filter_oembed_iframe_title_attribute
            [priority] => 5
            [function] => wp_filter_oembed_iframe_title_attribute
            [accepted_args] => 3
            [file] => /home/customer/www/eastofeverest.org/public_html/wp-includes/embed.php
            [line] => 842
        )

    [1] => Array
        (
            [id] => wp_filter_oembed_result
            [priority] => 10
            [function] => wp_filter_oembed_result
            [accepted_args] => 3
            [file] => /home/customer/www/eastofeverest.org/public_html/wp-includes/embed.php
            [line] => 909
        )

    [2] => Array
        (
            [id] => 0000000010f119e20000000011456d14_strip_newlines
            [priority] => 10
            [function] => Array
                (
                    [0] => WP_oEmbed
                    [1] => _strip_newlines
                )

            [accepted_args] => 3
            [file] => /home/customer/www/eastofeverest.org/public_html/wp-includes/class-wp-oembed.php
            [line] => 739
        )

    [3] => Array
        (
            [id] => NextgenthemesARVEfilter_oembed_dataparse
            [priority] => 9223372036854775807
            [function] => NextgenthemesARVEfilter_oembed_dataparse
            [accepted_args] => 3
            [file] => /home/customer/www/eastofeverest.org/public_html/wp-content/plugins/advanced-responsive-video-embedder/php/functions-oembed.php
            [line] => 15
        )

)

embed_oembed_html:
Array
(
    [0] => Array
        (
            [id] => NextgenthemesARVEfilter_embed_oembed_html
            [priority] => -5
            [function] => NextgenthemesARVEfilter_embed_oembed_html
            [accepted_args] => 4
            [file] => /home/customer/www/eastofeverest.org/public_html/wp-content/plugins/advanced-responsive-video-embedder/php/functions-oembed.php
            [line] => 35
        )

    [1] => Array
        (
            [id] => wp_maybe_enqueue_oembed_host_js
            [priority] => 10
            [function] => wp_maybe_enqueue_oembed_host_js
            [accepted_args] => 1
            [file] => /home/customer/www/eastofeverest.org/public_html/wp-includes/embed.php
            [line] => 388
        )

)

I have found two different plugin conflicts that affect ARVE video display and play. The first is that the current version of Siteground Optimizer freezes the video play. (I need to write Siteground about this.) I have now deactivated Siteground Optimizer for the present time.

This post refers to a second scenario: Video thumbnails are not displaying in post when the PowerKit plugin is activated. I used troubleshooting mode to establish this. Everything works fine, regardless of theme or other plugin until PowerKit is installed. (I have also written the PowerKit plugin’s author, but have heard nothing again yet.)

I read about thumbnails not appearing on some recent ARVE support posts. In my case, the thumbnail very briefly flashes and then disappears. I even manually added a thumbnail image, but the situation remains the same. The video play button is visible and the video plays; only, the thumbnail image is invisible, whether I upload my own or allow ARVE to display YouTube’s associated thumbnail.

There may be an oversight on my side. I only recently added a few videos on this website. Any help would be very appreciated.

Robert Posted new comment February 18, 2022

I also discovered today that when I enabled “minify” with the WP-Optimize Premium (3.2.2), video play also froze. I then unenabled this feature again and the behavior is back to how I described this in the my first description above: the thumbnail is missing. That said, there seems to also be something going on with the way that these optimization plugins (both Siteground’s and WP-Optimize) are interacting with ARVE, preventing video play and freezing the page. But I don’t know anything about this; I am only reporting the behavior. Thank you.

I have now had my hosting service look into this. They confirmed that there is nothing unusual on their side to make them think this problem originates from the server side.

Hello again. I know that you are busy, but I wonder if you have any ideas as to why thumbnails are not appearing on my site, using the pro version of the plugin. As noted already, I have even attached thumbnails myself, reading that this is sometimes necessary in some situations. I also noted that the plugin’s 2021-02-20 5.1.16 update addressed a situation where some thumbnails do not appear. The videos are playing and the video play button appears; only the thumbnail is not displaying. My website is installed on a multisite. Another site, using the same plugins (but not yet live/published) is not having any difficulty. Again, I will mention that my hosting service has confirmed that nothing seems strange on their end. Thank you. Your help/comments are appreciated.

I think that I have now isolated the cause of the conflict between PowerKit and ARVE. It appears to be the Pinterest module in the PowerKit plugin. The problem I described above is resolved when I disable/inactivate PowerKit’s Pinterest module, leaving all others active. Is now seems to me that this is probably a problem with the PowerKit module and that the problem has to be remedied there. Of course, my knowledge of all of this is so little that I do not know this for certain, but I have also been writing that plugin’s authors and updated them, as well. Still, if there is anything that is relevant to the problem on the ARVE side, I would appreciate knowing that.

This problem is now resolved. It arose when a cache/optimization plugin was not properly configured and somehow affected renderings of the PowerKit plugin. Though troubleshooting routinely PowerKit narrowed PowerKit as the plugin causing the behavior, when I changed cache settings, this problem was remedied. ARVE was in no way the cause, nor (it seems) the PowerKit plugin.