0
4 Comments

Tried with default theme: Yes

Tried with all other plugins disabled: Yes

Browser version: Chrome Version 71.0.3578.98

Debug Info:

ARVE Version:      8.10.3
ARVE-Pro Version:  4.2.5
WordPress Version: 5.0.3
PHP Version:       5.6.38

ACTIVE PLUGINS:
Advanced Custom Fields: ACF Code Field: 1.7
Advanced Custom Fields PRO: 5.7.10
Advanced Post Manager: 4.4
ARVE Advanced Responsive Video Embedder: 8.10.3
ARVE Pro Addon: 4.2.5
Better Notifications for WordPress: 1.7.2
Login With Ajax: 3.1.7
SSH SFTP Updater Support: 0.7.4

ARVE OPTIONS:
bool(false)
bool(false)
bool(false)
ARVE PRO OPTIONS:
bool(false)

RE: The “responsive” behavior is not working for the Classic Editor in a Gutenberg WP website.

We are in the process of upgrading our website to Gutenberg and testing all aspects of the website for possible issues from the upgrade, as the website is highly customized and includes a custom theme and many custom data-driven applications.

We use the ACF (Advanced Custom Fields) plugin for adding a vast number of custom fields to native and custom post-types. Many of our custom post-types have the Classic Editor (the pre-Gutenberg WYSIWYG). This editors (from ACF) has been retained by the ACF plugin for the Gutenberg release so it continues to function the same way it did prior to Gutenberg.

We use ARVE for the responsive video. It works fine in the Gutenberg blocks and classic block. But the “responsiveness” of embedded videos do not work in custom fields with the Classic WYSIWYG Editor. Any videos embedded in the Classic Editor (from ACF) stops working under Gutenberg.

We have a copy of the website without the Gutenberg release (to be phased out). The embeds work just fine in our pre-Gutenberg website with ARVE 8.9.7 and ARVE Pro 4.1.0.

Would it be possible to update your plugin so responsiveness function as expected for Classic Editors (i.e. from ACF)?

Answered question

I can not confirm anything of what you are saying as you did not provide a link. And I actually know that its works fine in Gutenberg. Did not test anything from ACF however. You also mention different and outdated ARVE versions in your text then those that are shown in the debug info.

The issue is specific to content (video) embedded in classic editors – such as the one provided by the ACF plugin. It happens after upgrading to Gutenberg and updating the plugins (standard and pro) to latest versions.

In our pre-Gutenberg site, the older plugins work just fine. We have not updated the plugins in our LIVE pre-Gutenberg site as we froze the site, while waiting for the Gutenberg tests and upgrade to complete on a test site.

The problem website (Gutenberg version) is in our local server. How can I share more info with you? I can screen grab. Do yo have a preference?

Not sure what you mean by screen-grab and preference but screenshots are not of any help in 99% of the cases. I need a live website to inspect with browser devtools to figure out what might be wrong with CSS classes and HTML structure causing this. If you do not have a staging site or something I really do now know what to do. This is just a guess but did you try enabling the “always load assets” option. Please give me the steps I need to do if I install ACF to reproduce this on latest WP and ARVE versions.

If screen grabs (animated GIF) is not helpful, we will be pushing the Gutenberg upgrade to our staging website soon. It’s currently on our DEV environment, in our local network. I can give you access once we move this to staging.

The responsive issues occur for ACF or other plugins, like the Events Calendar (by Modern Tribe), that use the classic Editor.

For now, if you want to test, you can simply install the ACF plugin in a Gutenberg version of WP website, add a WYSIWYG Editor custom field for a post type (i.e. posts or pages), add a YouTube video to one of the posts and see the result.

Symptoms:
Video has a max-width css style style embedded in the video wrapper DIV tag, causing the video to stop at 660px width instead of taking up available space.