0

Tried with default theme: Yes

Tried with all other plugins disabled: Yes

Browser version: Google Chrome is up to date Version 78.0.3904.70 (Official Build) (64-bit)

Shortcode/URL with the issue: https://vimeo.com/252104684

Page showing the issue: https://members.churchmarketinguniversity.com/courses/social-media/

Debug Info:

ARVE Version:      8.10.17
ARVE-Pro Version:  4.2.5 INACTIVE
WordPress Version: 5.2.4
PHP Version:       7.2.23-1+ubuntu16.04.1+deb.sury.org+1

ACTIVE PLUGINS:
Advanced Custom Fields PRO: 5.8.6
ARVE Advanced Responsive Video Embedder: 8.10.17
Disqus for WordPress: 3.0.17
Duplicate Page: 4.0
Envato Market: 2.0.3
Google Tag Manager for Wordpress: 1.10.1
Google XML Sitemaps: 4.1.0
i2SDK: 3.99
If Menu - Visibility control for menu items: 0.15
Invisible reCaptcha: 1.2.3
K Courses: 4.2.8
K Events: 4.2.8
K Shortcodes: 4.2.8
K Teachers: 4.2.8
Magee Shortcodes: 1.6.3
Memberium: 2.140
Redirection: 4.4.2
Slider Revolution: 6.1.3
TinyMCE Advanced: 5.2.1
WP Add Custom CSS: 1.1.5
WPBakery Page Builder: 6.0.5
Yoast SEO: 12.3

ARVE OPTIONS:
array(6) {
  ["mode"]=>
  string(8) "lazyload"
  ["last_settings_tab"]=>
  string(26) "#arve-settings-section-pro"
  ["controlslist"]=>
  string(0) ""
  ["iframe_flash"]=>
  bool(false)
  ["wp_video_override"]=>
  bool(false)
  ["wp_image_cache_time"]=>
  int(1)
}
array(0) {
}
array(0) {
}

When I turn on the ARVE Pro Add on the page load speed goes way up. The pages with more videos are failing to load all together for our customers. If I deactivate the plugin the page loads a ton faster. 

Question is closed for new answers.
Selected answer as best