0

Tried with default theme: Yes

Tried with all other plugins disabled: Yes

Browser version: Opera, Firefox, Chrome

Shortcode/URL with the issue: [arve url="https://youtu.be/apz1TQ2x8Ww" title="Intro2" mode="link-lightbox" sticky_pos="top-left" loop="no" muted="no" /]

Page showing the issue: https://www.yoga-steinfurth.de/zoom-test/

Debug Info:

ARVE:               9.4.2
ARVE Pro:           5.1.10
ARVE AMP:           NOT INSTALLED
ARVE Sticky Videos: NOT INSTALLED
ARVE Random Video:  NOT INSTALLED
WordPress Version:  5.6.1
PHP Version:        7.4.14
REST URL:           https://www.yoga-steinfurth.de/wp-json/nextgenthemes_arve/v1

ACTIVE PLUGINS:
Advanced Image Styles: 0.4.1
Antispam Bee: 2.9.3
ARVE Advanced Responsive Video Embedder: 9.4.2
ARVE Pro Addon: 5.1.10
BackWPup: 3.8.0
Classic Editor: 1.6
Contact Form 7: 5.3.2
Contact Form CFDB7: 1.2.5.8
Cookie Notice & Compliance for GDPR / CCPA: 2.0.2
Divi Lightbox for Images: 0.9.15
Events Manager: 5.9.10
Events Manager Pro: 2.6.4
Google Analyticator: 6.5.4
Honeypot for Contact Form 7: 1.14.1
ImageInject: 1.17
InfiniteWP - Client: 1.9.4.8.2
MailPoet 3 (New): 3.59.1
Monarch Plugin: 1.4.13
Redirection: 5.0.1
Responsive Like Box: 3.0.0
Shortcake (Shortcode UI): 0.7.4
Video Conferencing with Zoom: 3.6.26
Wordfence Security: 7.4.14
WordPress Importer: 0.7
WP-Polls: 2.75.5
WP Fastest Cache: 0.9.1.4
WP Statistics: 13.0.5
Yoast Duplicate Post: 4.1.1
Yoast SEO: 15.7


ARVE Options:
array(7) {
  ["mode"]=>
  string(8) "lightbox"
  ["maxwidth"]=>
  int(400)
  ["url_params_dailymotion"]=>
  string(48) "logo=0  hideInfos=1  related=0  forcedQuality=hd"
  ["url_params_liveleak"]=>
  string(17) "wmode=transparent"
  ["url_params_ustream"]=>
  string(22) "wmode=transparent  v=3"
  ["url_params_viddler"]=>
  string(54) "wmode=transparent  player=full  f=1  disablebranding=1"
  ["url_params_vimeo"]=>
  string(38) "html5=1  title=0  byline=0  portrait=0"
}

Dismissed Notices:
array(0) {
}

I am using Arve Pro on several sites with Divi Theme. Now I found out that the lightbox-link does not work anymore. I deactivated all plugins – still does not work. I deactivated Divi theme and used Theme twentyone instead – the lightbox-link shortcode did work again. Even when I don’t use the builder but the classic editor, the Shortcode does not work. On one page I am using Enable jQuery Migrate Helper – still does not work.

Do you have any idea, how to solve this?

Regards

Jürgen  

Posted new comment

Please ask the Elegantthemes support about this. They put this on the link data-et-has-event-already=”true” . And I am pretty sure et stands for Elegantthemes. They seem to mess with JavaScript events. I do not know what they do there. Please let me know if they can shed more light on this, if they can not outright fix I need at least know some hints what how they mess with JS events there.

Do you have issues with in the backend when creating ARVE embeds? Because last time I had to deal with Divi I came up with this https://nextgenthemes.com/app/uploads/2021/02/n-arve-divi-workaround.zip workaround plugin for someone else. I had to disable a specific filter related to oembed that disables previews completely but what needed on that specific site to make ARVE even work on the backend without some double reloading issue. If you also have this issue let me know and try the workaround plugin.

Hello Nico, thanks for your answer. I got some help from elegant themes. They suggested to wrap the arve Shortcode in a container with the class et_smooth_scroll_disabled:
[arve url="https://youtu.be/apz1TQ2x8Ww" title="Intro2" mode="link-lightbox" sticky_pos="top-left" loop="no" muted="no" /]

As this is quite complicated for editors, I use a site-wide javascript to add this class directly to the arve-link:

Maybe this helps other people also.

I have no other issues with divi, but thanks for the workaround plugin.

So, this is solved for me.

Oh the Javascript was deleted…

[code]

[/code]

Ehm, how can I add code?

(function($) {
$(document).ready(function() {

$(‘a.arve-lightbox-link’).addClass(‘et_smooth_scroll_disabled’);

});
})(jQuery);

just add the script tag before and after

Ok thanks if that class fixes it I will add it to the next version of the plugin directly in PHP.

Other plugins have problems with Divi smooth scroll also. See here, where I found the script:
https://wp-customerarea.com/support/topic/address-tab-not-working/

Thanks for looking in to future fixes for all 🙂