0

Tried with default theme: Yes

Tried with all other plugins disabled: No

Browser version: Chrome 88.0.4324.150

Shortcode/URL with the issue: https://youtu.be/VQGSoOkFIfo

Page showing the issue: https://www.kidlit.tv/2020/12/storymakers-with-zach-smith/

Debug Info:

ARVE:               9.5.1-beta6
ARVE Pro:           5.1.14
ARVE AMP:           NOT INSTALLED
ARVE Sticky Videos: NOT INSTALLED
ARVE Random Video:  NOT INSTALLED
WordPress Version:  5.6.1
PHP Version:        7.3.27
REST URL:           https://www.kidlit.tv/wp-json/nextgenthemes_arve/v1

ACTIVE PLUGINS:
Admin Columns Pro: 5.4.2
Admin Columns Pro - Advanced Custom Fields (ACF): 2.6.3
Advanced Comment Form: 1.2.0
Advanced Custom Fields PRO: 5.9.5
Advanced Editor Tools (previously TinyMCE Advanced): 5.6.0
Akismet Anti-Spam: 4.1.8
ARVE Advanced Responsive Video Embedder: 9.5.1-beta6
ARVE Pro Addon: 5.1.14
Audio Player by Clammr: 1.1.5
Black Studio TinyMCE Widget: 2.6.9
Blubrry PowerPress: 8.4.8
Classic Editor: 1.6
Custom Facebook Feed Pro Business: 3.18.2
Disable Admin Notices Individually: 1.2.6
Display Posts: 3.0.2
Enable Media Replace: 3.5.0
Extended Widget Options: 4.6.4
Flexible Posts Widget: 3.5.0
Gravity Forms: 2.4.22
Gravity Forms Mailchimp Add-On: 4.8
HTML Widget Text: 1.1
Intuitive Custom Post Order: 3.1.2.1
Jetpack by WordPress.com: 9.4
Juicer: 1.9.1
KidLit.TV Custom Types & Taxonomies: 1.0
Menu Social Icons: 1.3.10
Pretty Links Developer Edition: 3.2.1
Redirection: 5.0.1
Relevanssi: 4.11.0
SG Optimizer: 5.7.14
Shortcake (Shortcode UI): 0.7.4
ShortPixel Image Optimizer: 4.21.1
Site Kit by Google: 1.25.0
Tabby Responsive Tabs: 1.2.3
UpdraftPlus - Backup/Restore: 2.16.47.25
Video Conferencing with Zoom: 3.6.28
Video Thumbnails: 2.12.3
Webcraftic Assets manager: 2.0.7
Wordfence Security: 7.4.14
WordPress Post Type Archive Links: 1.3.1
Yoast SEO: 15.8
YotuWP - YouTube Gallery: 1.3.4.5
YotuWP Pro: 0.1.7


ARVE Options:
array(8) {
  ["mode"]=>
  string(8) "lightbox"
  ["thumbnail_post_image_fallback"]=>
  bool(true)
  ["hide_title"]=>
  bool(true)
  ["align"]=>
  string(6) "center"
  ["lightbox_maxwidth"]=>
  int(2000)
  ["align_maxwidth"]=>
  int(876)
  ["wp_video_override"]=>
  bool(false)
  ["youtube_nocookie"]=>
  bool(false)
}

Dismissed Notices:
array(0) {
}

You won’t be able to see this issue currently as I have switched the Mode from “Lightbox” to “Normal” so that the site isn’t broken for visitors. 

When Mode is set to “Lightbox”, any video embedded the default way (URL on its own line in the editor) will not play and no lightbox appears. Videos embedded using the ARVE shortcode work fine.

Here is what happens with non-shortcode embedded videos:

  1. On a post like https://www.kidlit.tv/2020/12/storymakers-with-zach-smith, Click on the video.
  2. The URL updates to https://www.kidlit.tv/2020/12/storymakers-with-zach-smith/#arve-youtube-vqgsookfifo602850c2e5d81194782722
  3. In the Console I see 2 errors and 1 warning:
    1. Warning: main.js?ver=5.1.14:1 Allow attribute will take precedence over ‘allowfullscreen’.
    2. https://www.kidlit.tv/2020/12/storymakers-with-zach-smith/none 404
      Image (async)
      e.exports @ main.js?ver=5.1.14:1
      S @ main.js?ver=5.1.14:1
      (anonymous) @ main.js?ver=5.1.14:1
    3. Uncaught TypeError: Cannot read property ‘dataset’ of null
      at k (main.js?ver=5.1.14:1)
      at animationStart (main.js?ver=5.1.14:1)
      at X (main.js?ver=5.1.14:1)
      k @ main.js?ver=5.1.14:1
      animationStart @ main.js?ver=5.1.14:1
      X @ main.js?ver=5.1.14:1
      error (async)
      (anonymous) @ main.js?ver=5.1.14:1
      e.exports @ main.js?ver=5.1.14:1
      S @ main.js?ver=5.1.14:1
      (anonymous) @ main.js?ver=5.1.14:1

Again, I couldn’t leave the lightbox functionality enabled as the admins of this site have not used the [arve] shortcode everywhere, meaning half the videos wouldn’t work. Let me know if I can help further in debugging! Thanks,

Michelle

Edited comment

9.5.1-beta6 has an issue where the plugin did not work properly I believe please try 9.5.1-beta8.

Not sure if this had anything to do with that, but hopefully.

Tried that and am now getting “oembed data needs to be null or an object” messages above videos, see https://www.kidlit.tv/2020/12/ready-set-draw-vanessa-brantley-newton-shows-make-collage/

It didn’t fix the lightbox issue either, that is still broken.