0

Tried with default theme: Yes

Tried with all other plugins disabled: Yes

Browser version: Google Chrome 72.0.3626.121 (64bit), Firefox 65.02 (32bit)

Debug Info:

ARVE Version:      8.10.4
ARVE-Pro Version:  NOT INSTALLED
WordPress Version: 5.1
PHP Version:       7.0.28

ACTIVE PLUGINS:
ARVE Advanced Responsive Video Embedder: 8.10.4
Disable Gutenberg: 1.6
Shortcake (Shortcode UI): 0.7.4

ARVE OPTIONS:
array(2) {
  ["last_settings_tab"]=>
  string(27) "#arve-settings-section-main"
  ["video_maxwidth"]=>
  string(0) ""
}
array(4) {
  ["dailymotion"]=>
  string(45) "logo=0&hideInfos=1&related=0&forcedQuality=hd"
  ["ustream"]=>
  string(21) "wmode=transparent&v=3"
  ["vimeo"]=>
  string(35) "html5=1&title=0&byline=0&portrait=0"
  ["dailymotionlist"]=>
  string(45) "logo=0&hideInfos=1&related=0&forcedQuality=hd"
}
array(0) {
}

I’m running ARVE (both, free and pro version on different WordPress blogs) and do have a weird issue that happens in both cases.

It seams to be a conflict between ARVE and Shortcake UI. The issue appears when ARVE and Shortcake UI both are installed and active while it disappears if Shortcake UI is deactivated. Problem is: I need Shortcake UI for other functions, so deactivating is not an option.

What happens is that when uploading images to the media gallery, images appears multiple times identically just with slighty different file names while WordPress claims that the upload failed (“An error occurred in the upload”).

How to reproduce the issue:

Add new post – add media – create gallery – upload files (and do so) – create new gallery – insert gallery – repeat adding a new gallery

-> uploading the file(s) for the second gallery result in the error message “file0040.jpg   An error occurred in the upload. Please try again later.”

In fact, the image files are being uploaded and multiplied in the media gallery. If you check, there are several identical images now with file names file0040-1.jpg, file0040-2.jpg etc.

This behavior can be stopped by saving the post after every gallery/image inserted into the post, which of course is pretty annoying.

I’ve tested this in three different WordPress blogs with different themes and in one cast (a test environment) with all other plugins deactivated.

So how can I use the ARVE and Shortcode UI plugins at the same time (as I did for years now and never had this issue; it started just recently).

Thanks and kind regards,
Franz

Edited comment

I think this is probably a issue with Shortcake UI and probably not a “conflict”. I am currently focusing on Gutenberg integration. Apart from that Shortcake is a 3rd party plugin I am not involved with with, I just utilize its functionality in ARVE and appears to not have much focus this days. You may want to report it to them anyway. I may have seen this issue, so the uploads show failed but they are actually stored in the gallery? Did you try to reopen the dialog after the fail and then add the already uploaded image from the gallery instead if uploading it again?

Thanks so far. The issue is: WordPress error message says that the upload failed, but in fact the upload was successful and the images are showing up at least four times, sometimes even ten or twelve times when I reopen the dialog. So I don’t try to upload images again, they’re there already, multiple times …

The point is: When I deactivate ARVE (while Shortcode UI is still active), the issue does not appear. When I re-activate, ARVE, the issue is there.

When you say you’re utilizing the functions of Shortcake UI, does that mean you have integrated parts of Shortcake UI int ARVE? Isn’t there a potential for conflict when your version of the code is slightly different from the one in the Shortcake UI plugin? Or that having the same code loaded into WordPress twice (via ARVE plugin and Shortcake UI plugin) causes conflicts?

I understood your the first time. But it seems you did not understand me. I was not suggesting your to reopen the dialog to try to reupload the image again but to SELECT the already uploaded image from the gallery instead.

So the image reupload themselves again and again just from opening the dialog or in the background or how does it happen exactly?

And no I do not reuse code form the plugin in my plugin the plugin is needed and my plugin hooks into it, other plugins need to register a shortcode and its attributes for shotcake UI to work. You have a wrong understanding about that, there is no duplicated code.

Okay, sorry, then I misunderstood what you were writing. I also understand now that you’re hooking into the existing Shortcake UI code, which explains why the issue doesn’t appear when Shortcake UI is disabled.

So, this is how exactly things are proceeding:
⦁ in the editor, click “add media” button
⦁ create gallery
⦁ (upload the images)
⦁ click on the “create new gallery” button
⦁ click in “insert gallery”

so far so good, all images uploaded and part of the gallery.

Now, when I then try to add another gallery with other images (without saving the draft posting in between), it goes like this:
⦁ in the editor, click “add media” button
⦁ create gallery
⦁ (upload the images)

-> results in “An error accurred in the upload. Please try again later.” for all uploaded pictures and pictures are only showing up as grey boxes
⦁ as the “create gallery” button is greyed out for the images just uploaded (with errors): close the modal window (x in the upper right corner)
⦁ Save Draft

Now if I click “add media” button, the images (that WP just claimed upload errors for) are already there, multiple times (in most cases: four time).

I’m not trying to re-upload them, they obviously are being uploaded multiple times already in the first place when WP claims the upload error. They just only appear in the media library after saving the posting (i.e. resetting all Javascript, I guess).

The simplest workaround would probably be if it was possible to prevent your plugin from hooking into Shortcake (which doesn’t seam to be necessary for the core functions or ARVE anyway)?

So its about the gallery dialog? I thought its about the ARVE dialog to add the thumbnail to a shortcode.

You still did not answer my question if you tried to close the dialog and on the next open just pick one of those uploaded images from the gallery (and delete the others). That was the workaround I would use.

I just tried to reproduce this but when I try to select images form the gallery in my dialog it shows me no images at all but I can see the multiple uploaded images if I go to the gallery directly. That might have to do with my development setup and it maybe unrelated. I also tied to reproduce this again on a fresh http://poopy.life WP site and was not able to reproduce it there.

From my tests its actually seems really about ARVE and Shortcake UI active at the same time but not 100% sure. So what makes you think its about ARVE? Did you try without ARVE but just shortcode UI active? From what you said it was not clear, I am just curious. I used the Classic Editor plugin to disable Gutenberg btw.

Still not worth much because, again, I did not write that plugin and I do not know how and do not want to spend time debugging it. Its extra functionality that either works or not for me right not sorry. The native GB block I am working on will be much better and based on natively supported WP code rather then some 3rd party plugin that seems not really maintained good.

It seems that you do not need Shortcode UI for ARVE or did I get that wrong? But you need it for other things? Yes I could put a filter or option in to prevent it from hooking into Shortcode UI to see if that helps.