Shortcode/URL with the issue: http://www.simoncorder.com/wp-content/uploads/2018/11/Knight-of-Illumination-Awards-2017-Simon-Corder.mp4

Page showing the issue: http://www.simoncorder.com/knight-of-illumination/

Debug Info:

Version of the browser you see the issue in (for example Firefox 52, do not say latest): Chrome Version 70.0.3538.77 (Official Build) (64-bit)

Link to test page on live site with the issue (do not change after posting): http://www.simoncorder.com/knight-of-illumination/

Shortcode(s) or URL(s) you used for embedding and have problems with:

Detailed Description of the issue:

What you are expecting and what you are seeing instead?

ARVE Version:      8.9.10
ARVE-Pro Version:  4.1.0
WordPress Version: 4.9.8
PHP Version:       5.6.38

ARVE Advanced Responsive Video Embedder: 8.9.10
ARVE Pro Addon: 4.1.0
Category Order and Taxonomy Terms Order: 1.5.5
Duplicate Post: 3.2.2
Mobile Menu: 2.6.1
NextGEN Gallery: 3.0.16
NextGEN Plus: 1.6.7
Post Tags and Categories for Pages: 1.4.1
Regenerate Thumbnails: 3.0.2
Shortcake (Shortcode UI): 0.7.3
TablePress: 1.9.1
Two Factor Authentication (Premium): 1.2.16
Unique Headers: 1.7.12
UpdraftPlus - Backup/Restore:

array(4) {
  string(4) "left"
  string(8) "lazyload"
  string(26) "#arve-settings-section-pro"
array(5) {
  string(45) "logo=0&hideInfos=1&related=0&forcedQuality=hd"
  string(29) "layout=4&height=340&width=560"
  string(21) "wmode=transparent&v=3"
  string(35) "html5=1&title=0&byline=0&portrait=0"
  string(45) "logo=0&hideInfos=1&related=0&forcedQuality=hd"
array(0) {
array(1) {
  string(6) "circle"

I love the ARVE Pro addon, added my own thumbnail to this video, which is the only one I’m hosting myself at the moment.

It looks great on Windows Microsoft Edge and on my iPad (both Chrome and Safari, but I believe they use the same engine)… but on Windows Chrome there’s a double play button.

Much appreciate if you can help, thanks, Simon

Question is closed for new answers.
Selected answer as best

Could you please delete your ARVE Pro Plugin and download the version 4.1.1 from the “my-account” page and install it and check if this resolves your issue? I have not yet released this version for everyone because its needs some testing.

Hi Nico – seems to have done the trick!