0

Tried with default theme: Yes

Tried with all other plugins disabled: No

Browser version: Chrome 87.0.4280.88 (Official Build) (64-bit)

Shortcode/URL with the issue: [arve url="http://techslides.com/demos/sample-videos/small.mp4" muted="no"/]

Hi,

Probably I have just missed something, but I couldn’t find documentation for the autoplayed video. I’ve set autoplay for HTML5 video in settings, but when the video starts, it’s muted. That makes the plugin senseless to me. Is there something I have missed in documentation, or any way at all to make the sound in autoplay on by default?

Answered question

Also found this attribute in the player code: muted=”muted by ARVE because autoplay is on”
So my question changes: is there any option to fix this behavior of the plugin?

found a line in php/functions-html-output.php:

‘muted’ => $autoplay ? ‘muted by ARVE because autoplay is on’ : $a[‘muted’],

changed to:

‘muted’ => $a[‘muted’],

So it works now as needed. Please add an option for this feature so this workaround could be changed back with native code. Thanks!