0

Tried with default theme: yes

Tried with all other plugins disabled: yes

Browser version: safari all

Shortcode/URL with the issue: [arve url="https://www.youtube.com/watch?v=HDckcHfLyb0&t=40s" /]

Page showing the issue: https://test5-grahamjohnclementsgmailcom.codeanyapp.com/test-post/

Debug Info:

ARVE:               9.7.5
ARVE Pro:           NOT INSTALLED
ARVE AMP:           NOT INSTALLED
ARVE Sticky Videos: NOT INSTALLED
ARVE Random Video:  NOT INSTALLED
WordPress Version:  5.9
PHP Version:        7.2.11-2+ubuntu16.04.1+deb.sury.org+1
REST URL:           https://test5-grahamjohnclementsgmailcom.codeanyapp.com/wp-json/nextgenthemes_arve/v1

ACTIVE PLUGINS:
ARVE Advanced Responsive Video Embedder: 9.7.5
Classic Editor: 1.6.2


ARVE Options:
array(0) {
}

Dismissed Notices:
array(0) {
}

oembed_dataparse:
Array
(
    [0] => Array
        (
            [id] => wp_filter_oembed_iframe_title_attribute
            [priority] => 5
            [function] => wp_filter_oembed_iframe_title_attribute
            [accepted_args] => 3
            [file] => /home/cabox/workspace/wp-includes/embed.php
            [line] => 842
        )

    [1] => Array
        (
            [id] => wp_filter_oembed_result
            [priority] => 10
            [function] => wp_filter_oembed_result
            [accepted_args] => 3
            [file] => /home/cabox/workspace/wp-includes/embed.php
            [line] => 909
        )

    [2] => Array
        (
            [id] => 0000000067b141580000000055362f59_strip_newlines
            [priority] => 10
            [function] => Array
                (
                    [0] => WP_oEmbed
                    [1] => _strip_newlines
                )

            [accepted_args] => 3
            [file] => /home/cabox/workspace/wp-includes/class-wp-oembed.php
            [line] => 739
        )

    [3] => Array
        (
            [id] => NextgenthemesARVEfilter_oembed_dataparse
            [priority] => 9223372036854775807
            [function] => NextgenthemesARVEfilter_oembed_dataparse
            [accepted_args] => 3
            [file] => /home/cabox/workspace/wp-content/plugins/advanced-responsive-video-embedder/php/functions-oembed.php
            [line] => 15
        )

)

embed_oembed_html:
Array
(
    [0] => Array
        (
            [id] => NextgenthemesARVEfilter_embed_oembed_html
            [priority] => -5
            [function] => NextgenthemesARVEfilter_embed_oembed_html
            [accepted_args] => 4
            [file] => /home/cabox/workspace/wp-content/plugins/advanced-responsive-video-embedder/php/functions-oembed.php
            [line] => 35
        )

    [1] => Array
        (
            [id] => wp_maybe_enqueue_oembed_host_js
            [priority] => 10
            [function] => wp_maybe_enqueue_oembed_host_js
            [accepted_args] => 1
            [file] => /home/cabox/workspace/wp-includes/embed.php
            [line] => 388
        )

)

ARVE does not work on an iphone, any version, any IOS, using classic editor. The problem first came to light on this website that uses the hello theme and elementor on all post pages that use arve videos https://gamesofdayne.com/2021/11/24/tandem-a-tale-of-shadows-review/ I then tried a different website with no plugins active except classic editor and arve. The video works on ipads and chrome, but not on an iphone. I checked using an online iphone simulator too. So there are hundreds of videos on this website, and at the moment it looks like my client will have to trawl through the posts and remove the arve shortcode and just leave the url name.  

Graham Clements Posted new comment February 23, 2022

I can tell that this page HTML code is not generated by the latest ARVE version.
https://gamesofdayne.com/2021/11/24/tandem-a-tale-of-shadows-review/

The test page you filled in above seems to run a newer version. Both pages do not work on Iphone? Did you test multiple Iphones of different people? What does “not work” mean exactly?

Yes they use different versions, which means the problem occurs with newer and older versions. The problem is simply this, on older iphones the videos refuse to play. On the games of dayne website there are other videos that don’t use arve and they work. ARVE is only used on the post pages, of which their are hundreds, that use classic editor.

What is older specifically? Try disabling the “sandbox” option and see if that works.

9.5.14. I turned off sandbox and the problem still occurs.