0

Tried with default theme: No

Tried with all other plugins disabled: No

Browser version: Brave

Page showing the issue: https://tosalem.com/artemisia-botanicals/?amp

Debug Info:

ARVE Version:      8.10.27
ARVE-Pro Version:  NOT INSTALLED
WordPress Version: 5.5
PHP Version:       7.4.9

ACTIVE PLUGINS:
ACF Content Analysis for Yoast SEO: 2.6
Ads for WPBakery Page Builder (formerly Visual Composer): 1.0.5
Advanced Ads: 1.19.1
Advanced Ads Pro: 2.9
Advanced Ads – Responsive Ads: 1.9.1
Advanced Custom Fields: 5.9.0
Akismet Anti-Spam: 4.1.6
AMP: 1.5.5
ARVE Advanced Responsive Video Embedder: 8.10.27
Classic Editor: 1.6
Contact Form 7: 5.2.1
ICS Calendar: 5.9.0.1
Lazy Load - Optimize Images: 2.3.4
List category posts: 0.83.1
Ninja Forms: 3.4.25
PublishPress Capabilities: 1.9.12
Redirection: 4.8
Shortcake (Shortcode UI): 0.7.4
Smush Pro: 3.6.3
Uncode Core: 2.2.8.3
Uncode Wireframes: 1.1.0
Uncode WPBakery Page Builder: 6.2.0
VC Particles Background: 1.3
WebP Express: 0.17.5
Web Stories: 1.0.0-beta.1
WP-Sweep: 1.1.3
WPBakery Page Builder (Visual Composer) Clipboard: 4.5.5.1
WPMU DEV Dashboard: 4.9.4
Yoast Duplicate Post: 3.2.5
Yoast SEO: 14.8

ARVE OPTIONS:
array(13) {
  ["align_maxwidth"]=>
  int(400)
  ["align"]=>
  string(6) "center"
  ["always_enqueue_assets"]=>
  bool(false)
  ["autoplay"]=>
  bool(false)
  ["mode"]=>
  string(8) "lazyload"
  ["promote_link"]=>
  bool(false)
  ["video_maxwidth"]=>
  string(0) ""
  ["wp_image_cache_time"]=>
  int(0)
  ["last_settings_tab"]=>
  string(0) ""
  ["wp_video_override"]=>
  bool(false)
  ["controlslist"]=>
  string(0) ""
  ["vimeo_api_token"]=>
  string(0) ""
  ["youtube_nocookie"]=>
  bool(false)
}
array(0) {
}
array(0) {
}

I’m having trouble validating amp pages with arve on them. I purchased the license for the amp addition and validated the license in the backend. The error I’m getting that causes the video to not load on amp pages looks like this:

Error code
DISALLOWED_ATTR
Invalid markup
<amp-iframe …<mark> name=""</mark> …>
Element attributes

allow
accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture

allowfullscreen
 

class
arve-iframe fitvidsignore amp-wp-enforced-sizes

frameborder
 

name
 

sandbox
allow-scripts allow-same-origin allow-presentation allow-popups allow-popups-to-escape-sandbox

scrolling
no

src
<a href="https://s.w.org/images/core/emoji/13.0.0/72x72/1f642.png" target="_blank" rel="noopener">https://s.w.org/images/core/emoji/13.0.0/72x72/1f642.png</a>

width
480

height
270

layout
intrinsic

Attribute name
name
Parent element
amp-iframe
Sources

 Source stack (2)

#1
Filter:
the_content

Post ID:
1833

Post Type:
Post (post)

Sources:

 Source stack (20)

#2
Type:
 Plugin

Name:
ARVE Advanced Responsive Video Embedder (advanced-responsive-video-embedder)

Function:
arve_shortcode()

Shortcode:
arve

Location:
public/functions-shortcodes.php:3

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 

 

Anyone got any ideas? Thanks for your help! 

Answered question